Back to overview
Resolved

Delayed updates in Installed Apps

Jun 12, 2026 at 5:15am UTC
Affected services
Flexxible Portal

Resolved
Jun 12, 2026 at 3:46pm UTC

The issue has been resolved and all systems are operating normally.

Created
Jun 12, 2026 at 5:15am UTC

Information regarding installed applications may be subject to delays in updating. This may cause discrepancies between recent changes and the data displayed. The root cause has been identified and the team is actively working to restore normal update times.